Debian 9 无法正常安装 Wine 3 解决方法

主题:
作者:anxin
日期:2018-06-15
分享:

Debian 9 系统中使用 Wine 官方提供的软件源安装 Wine 3 稳定版 sudo apt-get install --install-recommends winehq-stable 提示如下错误:

下列软件包有未满足的依赖关系:
 winehq-stable : 依赖: wine-stable (= 3.0.1~stretch)
E: 无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系。

1、Debian 9 安装 Wine 3 的错误原因

Debian 的 Apt 命名没有提供太多的错误原因,我们可以使用 Aptitude 查看更多的错误信息,运行如下命名:

sudo aptitude install  winehq-stable

运行命令后,在 Debian 9 系统中可能会提示如下类似的错误信息:

下列软件包存在未满足的依赖关系:
 libfontconfig1 : 破坏: libfontconfig1:i386 (!= 2.12.3-0.2) but 2.11.0-6.7+b1 is to be installed
 libfontconfig1:i386 : 破坏: libfontconfig1 (!= 2.11.0-6.7+b1) but 2.12.3-0.2 is installed

这说明在 Debian 9 系统中已经安装的一些软件包的版本,与需要安装的其他软件包版本不兼容,(本例中已经安装 libfontconfig1-2.12.3-0.2,与要安装的 libfontconfig1:i386-2.11.0-6.7+b1 不兼容)。

产生这个错误的原因是:你自己手动安装了一些软件包,这些软件包的版本高,而在安装依赖时,使用的是 Debian 9 软件源中的软件包,这与你手动安装的软件包版本不兼容。

2、Debian 9 解决无法安装 Wine 3

解决这个问题有两种途径:

1)把安装 Wine 3 时依赖的软件包的版本和你手动安装的软件包的版本一致,这样你需要手动下载所有依赖包(去 Debian Packages 下载相应的软件包),一一安装。

2)把你手动安装的软件包的版本替换为 Debian 9 软件源中相应的版本(去 Debian Packages 下载相应的软件包),然后使用 apt 命名安装 Wine 3。

本文链接:https://www.yuzhi100.com/article/debian-9-wufa-anzhuang-winehq

本文版权归知站所有,未经站长同意不得转载,谢谢尊重作者劳动成果!

作者:anxin