Debian 9 安装网易云音乐

主题:
作者:anxin
日期:2017-11-13
分享:

网易云音乐起步比较晚,但是拥有良好的用户体验,社区做的比较成功,现在是非常好用,并流行的一款音乐软件,同时网易云音乐拥有Linux版本,这无疑是Linux用户的福音。

本文介绍在 Debian 9 网易云音乐,本文安装的网易云音乐的版本是 Ubuntu 16.04 (64位)。

Debian 9 下安装网易云音乐

Linux版网易云音乐是基于Ubuntu开发的,所以在Debian 9上安装需要先解决一些依赖问题。

1)更新软件包fontconfig-config的版本

软件包fontconfig-configlibfontconfig1的依赖包,所以首先要更新fontconfig-config软件包,去Debian Packages下载最新版本fontconfig-config,当前的最新版是fontconfig-config_2.12.3-0.2

安装fontconfig-config最新版软件包

sudo dpkg -i fontconfig-config_2.12.3-0.2_all.deb

2)更新依赖包libfontconfig1的版本

网易云音乐对libfontconfig1依赖是:libfontconfig1 (>= 2.11.94),而在Debian 9系统下安装的版本是:2.11.0-6.7+b1,去Debian Packages下载最新版本libfontconfig1,当前的最新版是libfontconfig1_2.12.3-0.2

安装libfontconfig1最新版软件包

sudo dpkg -i libfontconfig1_2.12.3-0.2_amd64.deb

3)安装网易云音乐其他的依赖包

sudo apt-get install  libqt5multimedia5  libqt5xml5  gstreamer1.0-plugins-bad  libqt5multimedia5-plugins  libqt5multimediawidgets5

4)Debian 9 安装网易云音乐

sudo dpkg -i netease-cloud-music_1.0.0-2_amd64_ubuntu16.04.deb

如果你在Debian 9 安装网易云音乐时仍有未解决的依赖问题,查看:Debian 9 解决安装网易云音乐时的依赖问题

本文链接:https://www.yuzhi100.com/article/debian-9-anzhuang-wangyiyinyue

本文版权归知站所有,未经站长同意不得转载,谢谢尊重作者劳动成果!

作者:anxin